Proble with tree inside TabItem

Sep 2, 2008 at 1:17 AM
I'm having problems with trees inside tabitems, if a go to another item and get back, the tree is like frozen for expand, etc.
I can select items already open but I cant expand or unexpand containers.
I just have a 2 level structure.
Any idea??

PS. I have some fixes relating autosizing and a wrong method call for the icons expanded and not expanded.

Thanks
Sep 6, 2008 at 1:27 AM
is anybody working on this project???
Coordinator
Sep 7, 2008 at 9:02 AM
Hello,

Can you provide the repro?
Sep 7, 2008 at 6:43 PM
Hi,

The repro is like this:

1. A tab control, and some tabitems (build from code no xaml).
2. 2 treeviews inside tabitems (diferents)
3. when the app starts everithing works fine, a change to the other tab of the tabitem and everithing ok
4. when I get back to the first tabitem the events get duplicated. ex. one click is seen like a double click

any idea?

Thanks!
Coordinator
Sep 8, 2008 at 2:07 PM
Edited Sep 8, 2008 at 2:07 PM
Still no - that's why I asked you for code repro. It could be TreeView bug but it also could be your implementation of TabView/Treeview (like duplicate initialization of controls)...$0Can you upload your repro somewhere and post hyperlink here - I will get it and debug.$0
Sep 10, 2008 at 2:41 AM
ok, i get a demo of my problem is very simple, 2 tab items one treeview, at first everithing is ok but when you change tabitem and go back to de first the events fires twice.
I think is a bug of the tabitem what do you think??

SimpleTestProject
Coordinator
Sep 11, 2008 at 10:20 AM
Edited Sep 11, 2008 at 10:21 AM
Fixed. Get changeset #17392